summaryrefslogtreecommitdiffstats
path: root/test cases/unit/36 exe_wrapper behaviour/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/unit/36 exe_wrapper behaviour/meson.build')
-rw-r--r--test cases/unit/36 exe_wrapper behaviour/meson.build19
1 files changed, 19 insertions, 0 deletions
diff --git a/test cases/unit/36 exe_wrapper behaviour/meson.build b/test cases/unit/36 exe_wrapper behaviour/meson.build
new file mode 100644
index 0000000..d0817ba
--- /dev/null
+++ b/test cases/unit/36 exe_wrapper behaviour/meson.build
@@ -0,0 +1,19 @@
+project('exe wrapper behaviour', 'c')
+
+assert(meson.is_cross_build(), 'not setup as cross build')
+assert(meson.has_exe_wrapper(), 'exe wrapper not defined?') # intentionally not changed to can_run_host_binaries,
+
+exe = executable('prog', 'prog.c')
+
+if get_option('custom-target')
+ custom_target('use-exe-wrapper',
+ build_by_default: true,
+ output: 'out.txt',
+ command: [exe, '@OUTPUT@'])
+endif
+
+test('test-prog', exe)
+
+if get_option('run-target')
+ run_target('run-prog', command : exe)
+endif