summaryrefslogtreecommitdiffstats
path: root/test cases/unit/37 mixed command line args
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/unit/37 mixed command line args')
-rw-r--r--test cases/unit/37 mixed command line args/meson.build1
-rw-r--r--test cases/unit/37 mixed command line args/meson_options.txt10
2 files changed, 11 insertions, 0 deletions
diff --git a/test cases/unit/37 mixed command line args/meson.build b/test cases/unit/37 mixed command line args/meson.build
new file mode 100644
index 0000000..af5cdc7
--- /dev/null
+++ b/test cases/unit/37 mixed command line args/meson.build
@@ -0,0 +1 @@
+project('Mixed command line arguments')
diff --git a/test cases/unit/37 mixed command line args/meson_options.txt b/test cases/unit/37 mixed command line args/meson_options.txt
new file mode 100644
index 0000000..5a4bc22
--- /dev/null
+++ b/test cases/unit/37 mixed command line args/meson_options.txt
@@ -0,0 +1,10 @@
+option(
+ 'one',
+ type : 'string',
+)
+option(
+ 'two',
+ type : 'combo',
+ choices : ['foo', 'bar'],
+ value : 'foo',
+)