summaryrefslogtreecommitdiffstats
path: root/test cases/unit/38 pkgconfig format/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/unit/38 pkgconfig format/meson.build')
-rw-r--r--test cases/unit/38 pkgconfig format/meson.build18
1 files changed, 18 insertions, 0 deletions
diff --git a/test cases/unit/38 pkgconfig format/meson.build b/test cases/unit/38 pkgconfig format/meson.build
new file mode 100644
index 0000000..ea00f5d
--- /dev/null
+++ b/test cases/unit/38 pkgconfig format/meson.build
@@ -0,0 +1,18 @@
+project('pkgformat', 'c',
+ version : '1.0')
+
+gio = dependency('gio-2.0', required: false)
+if not gio.found()
+ error('MESON_SKIP_TEST glib not found.')
+endif
+
+pkgg = import('pkgconfig')
+
+s = static_library('returner', 'someret.c')
+l = library('something', 'somelib.c', link_whole: s)
+
+pkgg.generate(libraries: l,
+ version: '1.0',
+ name: 'libsomething',
+ description: 'A library that does something',
+ requires: 'gobject-2.0 >= 2.0, gio-2.0 >= 2.0')