summaryrefslogtreecommitdiffstats
path: root/test cases/unit/38 pkgconfig format
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/unit/38 pkgconfig format')
-rw-r--r--test cases/unit/38 pkgconfig format/meson.build18
-rw-r--r--test cases/unit/38 pkgconfig format/somelib.c7
-rw-r--r--test cases/unit/38 pkgconfig format/someret.c3
3 files changed, 28 insertions, 0 deletions
diff --git a/test cases/unit/38 pkgconfig format/meson.build b/test cases/unit/38 pkgconfig format/meson.build
new file mode 100644
index 0000000..ea00f5d
--- /dev/null
+++ b/test cases/unit/38 pkgconfig format/meson.build
@@ -0,0 +1,18 @@
+project('pkgformat', 'c',
+ version : '1.0')
+
+gio = dependency('gio-2.0', required: false)
+if not gio.found()
+ error('MESON_SKIP_TEST glib not found.')
+endif
+
+pkgg = import('pkgconfig')
+
+s = static_library('returner', 'someret.c')
+l = library('something', 'somelib.c', link_whole: s)
+
+pkgg.generate(libraries: l,
+ version: '1.0',
+ name: 'libsomething',
+ description: 'A library that does something',
+ requires: 'gobject-2.0 >= 2.0, gio-2.0 >= 2.0')
diff --git a/test cases/unit/38 pkgconfig format/somelib.c b/test cases/unit/38 pkgconfig format/somelib.c
new file mode 100644
index 0000000..0558024
--- /dev/null
+++ b/test cases/unit/38 pkgconfig format/somelib.c
@@ -0,0 +1,7 @@
+#include<stdio.h>
+
+int get_returnvalue (void);
+
+int some_func() {
+ return get_returnvalue();
+}
diff --git a/test cases/unit/38 pkgconfig format/someret.c b/test cases/unit/38 pkgconfig format/someret.c
new file mode 100644
index 0000000..69f4299
--- /dev/null
+++ b/test cases/unit/38 pkgconfig format/someret.c
@@ -0,0 +1,3 @@
+int get_returnvalue (void) {
+ return 0;
+}