summaryrefslogtreecommitdiffstats
path: root/test cases/unit/57 pkg_config_path option
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/unit/57 pkg_config_path option')
-rw-r--r--test cases/unit/57 pkg_config_path option/build_extra_path/totally_made_up_dep.pc7
-rw-r--r--test cases/unit/57 pkg_config_path option/host_extra_path/totally_made_up_dep.pc7
-rw-r--r--test cases/unit/57 pkg_config_path option/meson.build7
3 files changed, 21 insertions, 0 deletions
diff --git a/test cases/unit/57 pkg_config_path option/build_extra_path/totally_made_up_dep.pc b/test cases/unit/57 pkg_config_path option/build_extra_path/totally_made_up_dep.pc
new file mode 100644
index 0000000..5b149f6
--- /dev/null
+++ b/test cases/unit/57 pkg_config_path option/build_extra_path/totally_made_up_dep.pc
@@ -0,0 +1,7 @@
+prefix=/
+libdir=${prefix}/lib
+includedir=${prefix}/include
+
+Name: totally_made_up_dep
+Description: completely and totally made up for a test case
+Version: 4.5.6
diff --git a/test cases/unit/57 pkg_config_path option/host_extra_path/totally_made_up_dep.pc b/test cases/unit/57 pkg_config_path option/host_extra_path/totally_made_up_dep.pc
new file mode 100644
index 0000000..6d08687
--- /dev/null
+++ b/test cases/unit/57 pkg_config_path option/host_extra_path/totally_made_up_dep.pc
@@ -0,0 +1,7 @@
+prefix=/
+libdir=${prefix}/lib
+includedir=${prefix}/include
+
+Name: totally_made_up_dep
+Description: completely and totally made up for a test case
+Version: 1.2.3 \ No newline at end of file
diff --git a/test cases/unit/57 pkg_config_path option/meson.build b/test cases/unit/57 pkg_config_path option/meson.build
new file mode 100644
index 0000000..f9ceead
--- /dev/null
+++ b/test cases/unit/57 pkg_config_path option/meson.build
@@ -0,0 +1,7 @@
+project('pkg_config_path option')
+
+build = dependency('totally_made_up_dep', native: true, method : 'pkg-config')
+host = dependency('totally_made_up_dep', native: false, method : 'pkg-config')
+
+assert(build.version() == '4.5.6', 'wrong version for build machine dependency')
+assert(host.version() == '1.2.3', 'wrong version for host machine dependency')