summaryrefslogtreecommitdiffstats
path: root/test cases/unit/73 dep files/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/unit/73 dep files/meson.build')
-rw-r--r--test cases/unit/73 dep files/meson.build16
1 files changed, 16 insertions, 0 deletions
diff --git a/test cases/unit/73 dep files/meson.build b/test cases/unit/73 dep files/meson.build
new file mode 100644
index 0000000..4829f56
--- /dev/null
+++ b/test cases/unit/73 dep files/meson.build
@@ -0,0 +1,16 @@
+project('test', 'c')
+
+python = import('python').find_installation()
+
+lib = library('foo', 'foo.c')
+
+# The library does not yet exist but we can already use its path during
+# configuration. This should not trigger a reconfigure when the library is
+# rebuilt.
+configure_file(
+ output: 'out.txt',
+ capture: true,
+ command: [python, '-c', 'import sys; print(sys.argv[1])', lib.full_path()],
+)
+
+message('Project configured')