summaryrefslogtreecommitdiffstats
path: root/test cases/unit/87 run native test
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/unit/87 run native test')
-rw-r--r--test cases/unit/87 run native test/main.c17
-rw-r--r--test cases/unit/87 run native test/meson.build6
2 files changed, 23 insertions, 0 deletions
diff --git a/test cases/unit/87 run native test/main.c b/test cases/unit/87 run native test/main.c
new file mode 100644
index 0000000..3213780
--- /dev/null
+++ b/test cases/unit/87 run native test/main.c
@@ -0,0 +1,17 @@
+#include <stdio.h>
+
+int main (int argc, char * argv[])
+{
+ const char *out = "SUCCESS!";
+
+ if (argc != 2) {
+ printf ("%s\n", out);
+ } else {
+ int ret;
+ FILE *f = fopen (argv[1], "w");
+ ret = fwrite (out, sizeof (out), 1, f);
+ if (ret != 1)
+ return -1;
+ }
+ return 0;
+}
diff --git a/test cases/unit/87 run native test/meson.build b/test cases/unit/87 run native test/meson.build
new file mode 100644
index 0000000..3bf419c
--- /dev/null
+++ b/test cases/unit/87 run native test/meson.build
@@ -0,0 +1,6 @@
+project('run native test', ['c'])
+
+executable('terget_exe', 'main.c')
+
+native_exe = executable('native_exe', 'main.c', native: true)
+test('native_exe', native_exe, args: ['native_test_has_run.stamp'])