summaryrefslogtreecommitdiffstats
path: root/test cases/unit/9 d dedup
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/unit/9 d dedup')
-rw-r--r--test cases/unit/9 d dedup/meson.build5
-rw-r--r--test cases/unit/9 d dedup/prog.c14
2 files changed, 19 insertions, 0 deletions
diff --git a/test cases/unit/9 d dedup/meson.build b/test cases/unit/9 d dedup/meson.build
new file mode 100644
index 0000000..a7b6a82
--- /dev/null
+++ b/test cases/unit/9 d dedup/meson.build
@@ -0,0 +1,5 @@
+project('d dedup', 'c')
+
+add_project_arguments('-D', 'FOO', '-D', 'BAR', language : 'c')
+
+executable('prog', 'prog.c')
diff --git a/test cases/unit/9 d dedup/prog.c b/test cases/unit/9 d dedup/prog.c
new file mode 100644
index 0000000..505f122
--- /dev/null
+++ b/test cases/unit/9 d dedup/prog.c
@@ -0,0 +1,14 @@
+#include<stdio.h>
+
+#ifndef FOO
+#error FOO is not defined.
+#endif
+
+#ifndef BAR
+#error BAR is not defined.
+#endif
+
+int main(int argc, char **argv) {
+ printf("All is well.\n");
+ return 0;
+}