summaryrefslogtreecommitdiffstats
path: root/test cases/windows/11 exe implib/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/windows/11 exe implib/meson.build')
-rw-r--r--test cases/windows/11 exe implib/meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/test cases/windows/11 exe implib/meson.build b/test cases/windows/11 exe implib/meson.build
new file mode 100644
index 0000000..0a38ec1
--- /dev/null
+++ b/test cases/windows/11 exe implib/meson.build
@@ -0,0 +1,7 @@
+project('wintest', 'c')
+
+# Test that we can produce an implib for an executable on Windows, and that it's
+# name can be set, and that it is installed along with the executable
+
+executable('prog', 'prog.c', install: true, implib: true)
+executable('prog2', 'prog.c', install: true, implib: 'burble', install_dir: get_option('bindir'))