summaryrefslogtreecommitdiffstats
path: root/test cases/windows/21 masm/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/windows/21 masm/meson.build')
-rw-r--r--test cases/windows/21 masm/meson.build14
1 files changed, 14 insertions, 0 deletions
diff --git a/test cases/windows/21 masm/meson.build b/test cases/windows/21 masm/meson.build
new file mode 100644
index 0000000..b6b8fbb
--- /dev/null
+++ b/test cases/windows/21 masm/meson.build
@@ -0,0 +1,14 @@
+project('test-masm', 'c')
+
+if get_option('backend').startswith('vs')
+ error('MESON_SKIP_TEST: masm is not supported by vs backend')
+endif
+
+cc = meson.get_compiler('c')
+
+# MASM must be found when using MSVC, otherwise it is optional
+if not add_languages('masm', required: cc.get_argument_syntax() == 'msvc')
+ error('MESON_SKIP_TEST: masm not available')
+endif
+
+executable('app', 'hello.masm')