summaryrefslogtreecommitdiffstats
path: root/test cases/windows/8 find program/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/windows/8 find program/meson.build')
-rw-r--r--test cases/windows/8 find program/meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/test cases/windows/8 find program/meson.build b/test cases/windows/8 find program/meson.build
new file mode 100644
index 0000000..565fb62
--- /dev/null
+++ b/test cases/windows/8 find program/meson.build
@@ -0,0 +1,12 @@
+project('find program', 'c')
+
+# Test that we can find native windows executables
+find_program('cmd')
+find_program('cmd.exe')
+
+# Test that a script file with an extension can be found
+ext = find_program('test-script-ext.py')
+test('ext', ext)
+# Test that a script file without an extension can be found
+prog = find_program('test-script')
+test('script', prog)