summaryrefslogtreecommitdiffstats
path: root/collectors/ebpf.plugin/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 14:31:17 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 14:31:17 +0000
commit8020f71afd34d7696d7933659df2d763ab05542f (patch)
tree2fdf1b5447ffd8bdd61e702ca183e814afdcb4fc /collectors/ebpf.plugin/Makefile.am
parentInitial commit. (diff)
downloadnetdata-upstream.tar.xz
netdata-upstream.zip
Adding upstream version 1.37.1.upstream/1.37.1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'collectors/ebpf.plugin/Makefile.am')
-rw-r--r--collectors/ebpf.plugin/Makefile.am42
1 files changed, 42 insertions, 0 deletions
diff --git a/collectors/ebpf.plugin/Makefile.am b/collectors/ebpf.plugin/Makefile.am
new file mode 100644
index 0000000..2d5f92a
--- /dev/null
+++ b/collectors/ebpf.plugin/Makefile.am
@@ -0,0 +1,42 @@
+# SPDX-License-Identifier: GPL-3.0-or-later
+
+AUTOMAKE_OPTIONS = subdir-objects
+MAINTAINERCLEANFILES = $(srcdir)/Makefile.in
+
+include $(top_srcdir)/build/subst.inc
+SUFFIXES = .in
+
+userebpfconfigdir=$(configdir)/ebpf.d
+
+# Explicitly install directories to avoid permission issues due to umask
+install-exec-local:
+ $(INSTALL) -d $(DESTDIR)$(userebpfconfigdir)
+
+dist_noinst_DATA = \
+ README.md \
+ $(NULL)
+
+ebpfconfigdir=$(libconfigdir)/ebpf.d
+dist_libconfig_DATA = \
+ ebpf.d.conf \
+ $(NULL)
+
+dist_ebpfconfig_DATA = \
+ ebpf.d/ebpf_kernel_reject_list.txt \
+ ebpf.d/cachestat.conf \
+ ebpf.d/dcstat.conf \
+ ebpf.d/disk.conf \
+ ebpf.d/fd.conf \
+ ebpf.d/filesystem.conf \
+ ebpf.d/hardirq.conf \
+ ebpf.d/mdflush.conf \
+ ebpf.d/mount.conf \
+ ebpf.d/network.conf \
+ ebpf.d/oomkill.conf \
+ ebpf.d/process.conf \
+ ebpf.d/shm.conf \
+ ebpf.d/softirq.conf \
+ ebpf.d/sync.conf \
+ ebpf.d/swap.conf \
+ ebpf.d/vfs.conf \
+ $(NULL)