summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:08:25 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 14:08:25 +0000
commit9e17310da22d193009533ae8983ab5e25d982a95 (patch)
tree93f9355d2303d82ce0dc15c1ca52eb784713f9ae
parentSetting default ECDSA size in ssh-keygen to 521. (diff)
downloadopenssh-9e17310da22d193009533ae8983ab5e25d982a95.tar.xz
openssh-9e17310da22d193009533ae8983ab5e25d982a95.zip
Removing small diffie-hellman moduli.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rwxr-xr-xdebian/rules4
1 files changed, 4 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 18b2bf3..9dc2801 100755
--- a/debian/rules
+++ b/debian/rules
@@ -163,6 +163,10 @@ override_dh_install-arch:
debian/tmp/etc/ssh/ssh_config \
debian/tmp/etc/ssh/sshd_config
+ # Remove small Diffie-Hellman moduli
+ awk '$$5 >= 4095' debian/tmp/etc/ssh/moduli > debian/tmp/etc/ssh/moduli.tmp
+ mv -f debian/tmp/etc/ssh/moduli.tmp debian/tmp/etc/ssh/moduli
+
dh_install -Nopenssh-client-udeb -Nopenssh-server-udeb
ifeq ($(filter noudeb,$(DEB_BUILD_PROFILES)),)
dh_install -popenssh-client-udeb -popenssh-server-udeb \