summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 09:43:18 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-28 09:43:18 +0000
commitcc5717cdf86886c3dbaea40dfc8dc9e501b1cf1f (patch)
tree2dae3914f7c48ebc5d0e27e9d3bdbaea8210a30f /test/Makefile.am
parentInitial commit. (diff)
downloadopentracing-c-wrapper-upstream.tar.xz
opentracing-c-wrapper-upstream.zip
Adding upstream version 1.1.3.upstream/1.1.3upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
new file mode 100644
index 0000000..72b61e7
--- /dev/null
+++ b/test/Makefile.am
@@ -0,0 +1,23 @@
+## Process this file with automake to produce Makefile.in
+##
+ AM_CPPFLAGS = -I\$(top_builddir)/include -I$(srcdir)/../include @OPENTRACING_C_WRAPPER_CPPFLAGS@
+ AM_CFLAGS = @OPENTRACING_C_WRAPPER_CFLAGS@
+ AM_LDFLAGS = @OPENTRACING_C_WRAPPER_LDFLAGS@
+
+if WANT_DEBUG
+ bin_PROGRAMS = ot-c-wrapper-test_dbg
+ot_c_wrapper_test_dbg_SOURCES = opentracing.c test.c util.c
+ ot_c_wrapper_test_dbg_LDADD = -lstdc++ -lm @OPENTRACING_C_WRAPPER_LIBS@ $(top_builddir)/src/libopentracing-c-wrapper_dbg.la
+ot_c_wrapper_test_dbg_LDFLAGS = @OPENTRACING_C_WRAPPER_LDFLAGS@
+
+else
+
+ bin_PROGRAMS = ot-c-wrapper-test
+ot_c_wrapper_test_SOURCES = opentracing.c test.c util.c
+ ot_c_wrapper_test_LDADD = -lstdc++ -lm @OPENTRACING_C_WRAPPER_LIBS@ $(top_builddir)/src/libopentracing-c-wrapper.la
+ot_c_wrapper_test_LDFLAGS = @OPENTRACING_C_WRAPPER_LDFLAGS@
+endif
+
+CLEANFILES = a.out
+##
+## Makefile.am ends here