summaryrefslogtreecommitdiffstats
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/fix-ac-packagename.patch18
-rw-r--r--debian/patches/remove-rpath-from-pc.patch15
-rw-r--r--debian/patches/series2
3 files changed, 35 insertions, 0 deletions
diff --git a/debian/patches/fix-ac-packagename.patch b/debian/patches/fix-ac-packagename.patch
new file mode 100644
index 0000000..50f3fce
--- /dev/null
+++ b/debian/patches/fix-ac-packagename.patch
@@ -0,0 +1,18 @@
+Description: Hard-code the autoconf package name. Debian includes the version
+ number in the directory name so it gets set to the wrong name and thereby
+ generates the wrong .pc file
+Forwarded: not-needed
+Author: Stephen Gelman <ssgelm@debian.org>
+Last-Update: 2021-07-29
+---
+--- a/configure.ac
++++ b/configure.ac
+@@ -4,7 +4,7 @@
+
+ AC_PREREQ([2.69])
+ AC_COPYRIGHT([Copyright (C) 2020 HAProxy Technologies])
+-AC_INIT(m4_esyscmd_s([basename ${PWD}]), m4_esyscmd_s([awk '/Package/ { print $3 }' VERSION]), [mzagorac@haproxy.com])
++AC_INIT([opentracing-c-wrapper], m4_esyscmd_s([awk '/Package/ { print $3 }' VERSION]), [mzagorac@haproxy.com])
+ AC_CONFIG_MACRO_DIR([m4])
+ AX_VARIABLE_SET([LIB_VERSION], m4_esyscmd_s([awk '/Library/ { print $3 }' VERSION]))
+
diff --git a/debian/patches/remove-rpath-from-pc.patch b/debian/patches/remove-rpath-from-pc.patch
new file mode 100644
index 0000000..fbd53fa
--- /dev/null
+++ b/debian/patches/remove-rpath-from-pc.patch
@@ -0,0 +1,15 @@
+Description: Remove rpath from the PC file. Since debian is installing to the
+ /usr prefix, it's unnecessary and generates a lintian warning.
+Forwarded: not-needed
+Author: Stephen Gelman <ssgelm@debian.org>
+Last-Update: 2021-11-11
+---
+--- a/opentracing-c-wrapper.pc.in
++++ b/opentracing-c-wrapper.pc.in
+@@ -8,5 +8,5 @@
+ Version: @VERSION@
+
+ Requires:
+-Libs: -L${libdir} -Wl,--rpath,${libdir} -lopentracing-c-wrapper
++Libs: -L${libdir} -lopentracing-c-wrapper
+ Cflags: -I${includedir}
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..c3bb613
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,2 @@
+fix-ac-packagename.patch
+remove-rpath-from-pc.patch