summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules20
1 files changed, 20 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..25297c0
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,20 @@
+#!/usr/bin/make -f
+
+include /usr/share/dpkg/buildtools.mk
+
+%:
+ dh ${@}
+
+override_dh_auto_configure:
+ dh_auto_configure -- 'CC=$(CC)'
+
+override_dh_auto_install:
+ dh_auto_install -- DESTDIR=$(CURDIR)/debian/pdlzip
+
+execute_after_dh_auto_install:
+ # update-alternatives
+ mv debian/pdlzip/usr/bin/pdlzip debian/pdlzip/usr/bin/lzip.pdlzip
+ ln -s /usr/bin/lzip.pdlzip debian/pdlzip/usr/bin/pdlzip
+
+ mv debian/pdlzip/usr/share/man/man1/pdlzip.1 debian/pdlzip/usr/share/man/man1/lzip.pdlzip.1
+ ln -s /usr/share/man/man1/lzip.pdlzip.1.gz debian/pdlzip/usr/share/man/man1/pdlzip.1.gz