summaryrefslogtreecommitdiffstats
path: root/contrib/pageinspect/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:19:15 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:19:15 +0000
commit6eb9c5a5657d1fe77b55cc261450f3538d35a94d (patch)
tree657d8194422a5daccecfd42d654b8a245ef7b4c8 /contrib/pageinspect/Makefile
parentInitial commit. (diff)
downloadpostgresql-13-6eb9c5a5657d1fe77b55cc261450f3538d35a94d.tar.xz
postgresql-13-6eb9c5a5657d1fe77b55cc261450f3538d35a94d.zip
Adding upstream version 13.4.upstream/13.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'contrib/pageinspect/Makefile')
-rw-r--r--contrib/pageinspect/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/contrib/pageinspect/Makefile b/contrib/pageinspect/Makefile
new file mode 100644
index 0000000..d9d8177
--- /dev/null
+++ b/contrib/pageinspect/Makefile
@@ -0,0 +1,33 @@
+# contrib/pageinspect/Makefile
+
+MODULE_big = pageinspect
+OBJS = \
+ $(WIN32RES) \
+ brinfuncs.o \
+ btreefuncs.o \
+ fsmfuncs.o \
+ ginfuncs.o \
+ hashfuncs.o \
+ heapfuncs.o \
+ rawpage.o
+
+EXTENSION = pageinspect
+DATA = pageinspect--1.7--1.8.sql pageinspect--1.6--1.7.sql \
+ pageinspect--1.5.sql pageinspect--1.5--1.6.sql \
+ pageinspect--1.4--1.5.sql pageinspect--1.3--1.4.sql \
+ pageinspect--1.2--1.3.sql pageinspect--1.1--1.2.sql \
+ pageinspect--1.0--1.1.sql
+PGFILEDESC = "pageinspect - functions to inspect contents of database pages"
+
+REGRESS = page btree brin gin hash checksum
+
+ifdef USE_PGXS
+PG_CONFIG = pg_config
+PGXS := $(shell $(PG_CONFIG) --pgxs)
+include $(PGXS)
+else
+subdir = contrib/pageinspect
+top_builddir = ../..
+include $(top_builddir)/src/Makefile.global
+include $(top_srcdir)/contrib/contrib-global.mk
+endif