summaryrefslogtreecommitdiffstats
path: root/src/backend/nls.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:19:15 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:19:15 +0000
commit6eb9c5a5657d1fe77b55cc261450f3538d35a94d (patch)
tree657d8194422a5daccecfd42d654b8a245ef7b4c8 /src/backend/nls.mk
parentInitial commit. (diff)
downloadpostgresql-13-upstream.tar.xz
postgresql-13-upstream.zip
Adding upstream version 13.4.upstream/13.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/backend/nls.mk')
-rw-r--r--src/backend/nls.mk28
1 files changed, 28 insertions, 0 deletions
diff --git a/src/backend/nls.mk b/src/backend/nls.mk
new file mode 100644
index 0000000..c954cd3
--- /dev/null
+++ b/src/backend/nls.mk
@@ -0,0 +1,28 @@
+# src/backend/nls.mk
+CATALOG_NAME = postgres
+AVAIL_LANGUAGES = de es fr it ja ko ru sv tr uk zh_CN
+GETTEXT_FILES = + gettext-files
+GETTEXT_TRIGGERS = $(BACKEND_COMMON_GETTEXT_TRIGGERS) \
+ GUC_check_errmsg \
+ GUC_check_errdetail \
+ GUC_check_errhint \
+ write_stderr \
+ yyerror \
+ parser_yyerror \
+ scanner_yyerror \
+ report_invalid_record:2
+GETTEXT_FLAGS = $(BACKEND_COMMON_GETTEXT_FLAGS) \
+ GUC_check_errmsg:1:c-format \
+ GUC_check_errdetail:1:c-format \
+ GUC_check_errhint:1:c-format \
+ write_stderr:1:c-format \
+ report_invalid_record:2:c-format
+
+gettext-files: distprep
+ find $(srcdir) $(srcdir)/../common $(srcdir)/../port -name '*.c' -print | LC_ALL=C sort >$@
+
+my-clean:
+ rm -f gettext-files
+
+.PHONY: my-clean
+clean: my-clean