summaryrefslogtreecommitdiffstats
path: root/src/makefiles/Makefile.darwin
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:19:15 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:19:15 +0000
commit6eb9c5a5657d1fe77b55cc261450f3538d35a94d (patch)
tree657d8194422a5daccecfd42d654b8a245ef7b4c8 /src/makefiles/Makefile.darwin
parentInitial commit. (diff)
downloadpostgresql-13-6eb9c5a5657d1fe77b55cc261450f3538d35a94d.tar.xz
postgresql-13-6eb9c5a5657d1fe77b55cc261450f3538d35a94d.zip
Adding upstream version 13.4.upstream/13.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/makefiles/Makefile.darwin')
-rw-r--r--src/makefiles/Makefile.darwin16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/makefiles/Makefile.darwin b/src/makefiles/Makefile.darwin
new file mode 100644
index 0000000..b17598f
--- /dev/null
+++ b/src/makefiles/Makefile.darwin
@@ -0,0 +1,16 @@
+AROPT = crs
+
+DLSUFFIX = .so
+
+# env var name to use in place of LD_LIBRARY_PATH
+ld_library_path_var = DYLD_LIBRARY_PATH
+
+ifdef PGXS
+ BE_DLLLIBS = -bundle_loader $(bindir)/postgres
+else
+ BE_DLLLIBS = -bundle_loader $(top_builddir)/src/backend/postgres
+endif
+
+# Rule for building a shared library from a single .o file
+%.so: %.o
+ $(CC) $(CFLAGS) $< $(LDFLAGS) $(LDFLAGS_SL) -bundle $(BE_DLLLIBS) -o $@