summaryrefslogtreecommitdiffstats
path: root/src/pl/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:19:15 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:19:15 +0000
commit6eb9c5a5657d1fe77b55cc261450f3538d35a94d (patch)
tree657d8194422a5daccecfd42d654b8a245ef7b4c8 /src/pl/Makefile
parentInitial commit. (diff)
downloadpostgresql-13-6eb9c5a5657d1fe77b55cc261450f3538d35a94d.tar.xz
postgresql-13-6eb9c5a5657d1fe77b55cc261450f3538d35a94d.zip
Adding upstream version 13.4.upstream/13.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/pl/Makefile')
-rw-r--r--src/pl/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/src/pl/Makefile b/src/pl/Makefile
new file mode 100644
index 0000000..c4a0d1c
--- /dev/null
+++ b/src/pl/Makefile
@@ -0,0 +1,36 @@
+#-------------------------------------------------------------------------
+#
+# Makefile for src/pl (procedural languages)
+#
+# Copyright (c) 1994, Regents of the University of California
+#
+# src/pl/Makefile
+#
+#-------------------------------------------------------------------------
+
+subdir = src/pl
+top_builddir = ../..
+include $(top_builddir)/src/Makefile.global
+
+SUBDIRS = plpgsql
+
+ifeq ($(with_perl), yes)
+SUBDIRS += plperl
+else
+ALWAYS_SUBDIRS += plperl
+endif
+
+ifeq ($(with_python), yes)
+SUBDIRS += plpython
+else
+ALWAYS_SUBDIRS += plpython
+endif
+
+ifeq ($(with_tcl), yes)
+SUBDIRS += tcl
+else
+ALWAYS_SUBDIRS += tcl
+endif
+
+$(recurse)
+$(recurse_always)