summaryrefslogtreecommitdiffstats
path: root/contrib/fuzzystrmatch/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/fuzzystrmatch/Makefile')
-rw-r--r--contrib/fuzzystrmatch/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/contrib/fuzzystrmatch/Makefile b/contrib/fuzzystrmatch/Makefile
new file mode 100644
index 0000000..0704894
--- /dev/null
+++ b/contrib/fuzzystrmatch/Makefile
@@ -0,0 +1,24 @@
+# contrib/fuzzystrmatch/Makefile
+
+MODULE_big = fuzzystrmatch
+OBJS = \
+ $(WIN32RES) \
+ dmetaphone.o \
+ fuzzystrmatch.o
+
+EXTENSION = fuzzystrmatch
+DATA = fuzzystrmatch--1.1.sql fuzzystrmatch--1.0--1.1.sql
+PGFILEDESC = "fuzzystrmatch - similarities and distance between strings"
+
+REGRESS = fuzzystrmatch
+
+ifdef USE_PGXS
+PG_CONFIG = pg_config
+PGXS := $(shell $(PG_CONFIG) --pgxs)
+include $(PGXS)
+else
+subdir = contrib/fuzzystrmatch
+top_builddir = ../..
+include $(top_builddir)/src/Makefile.global
+include $(top_srcdir)/contrib/contrib-global.mk
+endif