summaryrefslogtreecommitdiffstats
path: root/contrib/intarray/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/intarray/Makefile')
-rw-r--r--contrib/intarray/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/contrib/intarray/Makefile b/contrib/intarray/Makefile
new file mode 100644
index 0000000..b68959e
--- /dev/null
+++ b/contrib/intarray/Makefile
@@ -0,0 +1,30 @@
+# contrib/intarray/Makefile
+
+MODULE_big = _int
+OBJS = \
+ $(WIN32RES) \
+ _int_bool.o \
+ _int_gin.o \
+ _int_gist.o \
+ _int_op.o \
+ _int_selfuncs.o \
+ _int_tool.o \
+ _intbig_gist.o
+
+EXTENSION = intarray
+DATA = intarray--1.2--1.3.sql intarray--1.2.sql intarray--1.1--1.2.sql \
+ intarray--1.0--1.1.sql
+PGFILEDESC = "intarray - functions and operators for arrays of integers"
+
+REGRESS = _int
+
+ifdef USE_PGXS
+PG_CONFIG = pg_config
+PGXS := $(shell $(PG_CONFIG) --pgxs)
+include $(PGXS)
+else
+subdir = contrib/intarray
+top_builddir = ../..
+include $(top_builddir)/src/Makefile.global
+include $(top_srcdir)/contrib/contrib-global.mk
+endif