summaryrefslogtreecommitdiffstats
path: root/contrib/isn/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/isn/Makefile')
-rw-r--r--contrib/isn/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/contrib/isn/Makefile b/contrib/isn/Makefile
new file mode 100644
index 0000000..1037506
--- /dev/null
+++ b/contrib/isn/Makefile
@@ -0,0 +1,24 @@
+# contrib/isn/Makefile
+
+MODULES = isn
+
+EXTENSION = isn
+DATA = isn--1.1.sql isn--1.1--1.2.sql \
+ isn--1.0--1.1.sql
+PGFILEDESC = "isn - data types for international product numbering standards"
+
+# the other .h files are data tables, we don't install those
+HEADERS_isn = isn.h
+
+REGRESS = isn
+
+ifdef USE_PGXS
+PG_CONFIG = pg_config
+PGXS := $(shell $(PG_CONFIG) --pgxs)
+include $(PGXS)
+else
+subdir = contrib/isn
+top_builddir = ../..
+include $(top_builddir)/src/Makefile.global
+include $(top_srcdir)/contrib/contrib-global.mk
+endif