summaryrefslogtreecommitdiffstats
path: root/contrib/pg_buffercache/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/pg_buffercache/Makefile')
-rw-r--r--contrib/pg_buffercache/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/contrib/pg_buffercache/Makefile b/contrib/pg_buffercache/Makefile
new file mode 100644
index 0000000..2ab8c65
--- /dev/null
+++ b/contrib/pg_buffercache/Makefile
@@ -0,0 +1,22 @@
+# contrib/pg_buffercache/Makefile
+
+MODULE_big = pg_buffercache
+OBJS = \
+ $(WIN32RES) \
+ pg_buffercache_pages.o
+
+EXTENSION = pg_buffercache
+DATA = pg_buffercache--1.2.sql pg_buffercache--1.2--1.3.sql \
+ pg_buffercache--1.1--1.2.sql pg_buffercache--1.0--1.1.sql
+PGFILEDESC = "pg_buffercache - monitoring of shared buffer cache in real-time"
+
+ifdef USE_PGXS
+PG_CONFIG = pg_config
+PGXS := $(shell $(PG_CONFIG) --pgxs)
+include $(PGXS)
+else
+subdir = contrib/pg_buffercache
+top_builddir = ../..
+include $(top_builddir)/src/Makefile.global
+include $(top_srcdir)/contrib/contrib-global.mk
+endif