summaryrefslogtreecommitdiffstats
path: root/contrib/sepgsql/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/sepgsql/Makefile')
-rw-r--r--contrib/sepgsql/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/contrib/sepgsql/Makefile b/contrib/sepgsql/Makefile
new file mode 100644
index 0000000..afca75b
--- /dev/null
+++ b/contrib/sepgsql/Makefile
@@ -0,0 +1,33 @@
+# contrib/sepgsql/Makefile
+
+MODULE_big = sepgsql
+OBJS = \
+ $(WIN32RES) \
+ database.o \
+ dml.o \
+ hooks.o \
+ label.o \
+ proc.o \
+ relation.o \
+ schema.o \
+ selinux.o \
+ uavc.o
+DATA_built = sepgsql.sql
+PGFILEDESC = "sepgsql - SELinux integration"
+
+# Note: because we don't tell the Makefile there are any regression tests,
+# we have to clean those result files explicitly
+EXTRA_CLEAN = -r $(pg_regress_clean_files) tmp/ *.pp sepgsql-regtest.if sepgsql-regtest.fc
+
+ifdef USE_PGXS
+PG_CONFIG = pg_config
+PGXS := $(shell $(PG_CONFIG) --pgxs)
+include $(PGXS)
+else
+subdir = contrib/sepgsql
+top_builddir = ../..
+include $(top_builddir)/src/Makefile.global
+include $(top_srcdir)/contrib/contrib-global.mk
+endif
+
+SHLIB_LINK += -lselinux