summaryrefslogtreecommitdiffstats
path: root/contrib/spi/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/spi/Makefile')
-rw-r--r--contrib/spi/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/contrib/spi/Makefile b/contrib/spi/Makefile
new file mode 100644
index 0000000..c9c34ff
--- /dev/null
+++ b/contrib/spi/Makefile
@@ -0,0 +1,28 @@
+# contrib/spi/Makefile
+
+MODULES = autoinc insert_username moddatetime refint
+
+EXTENSION = autoinc insert_username moddatetime refint
+
+DATA = autoinc--1.0.sql \
+ insert_username--1.0.sql \
+ moddatetime--1.0.sql \
+ refint--1.0.sql
+PGFILEDESC = "spi - examples of using SPI and triggers"
+
+DOCS = $(addsuffix .example, $(MODULES))
+
+# this is needed for the regression tests;
+# comment out if you want a quieter refint package for other uses
+PG_CPPFLAGS = -DREFINT_VERBOSE
+
+ifdef USE_PGXS
+PG_CONFIG = pg_config
+PGXS := $(shell $(PG_CONFIG) --pgxs)
+include $(PGXS)
+else
+subdir = contrib/spi
+top_builddir = ../..
+include $(top_builddir)/src/Makefile.global
+include $(top_srcdir)/contrib/contrib-global.mk
+endif