summaryrefslogtreecommitdiffstats
path: root/contrib/tablefunc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/tablefunc/Makefile')
-rw-r--r--contrib/tablefunc/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/contrib/tablefunc/Makefile b/contrib/tablefunc/Makefile
new file mode 100644
index 0000000..191a3a1
--- /dev/null
+++ b/contrib/tablefunc/Makefile
@@ -0,0 +1,22 @@
+# contrib/tablefunc/Makefile
+
+MODULES = tablefunc
+
+EXTENSION = tablefunc
+DATA = tablefunc--1.0.sql
+PGFILEDESC = "tablefunc - various functions that return tables"
+
+REGRESS = tablefunc
+
+LDFLAGS_SL += $(filter -lm, $(LIBS))
+
+ifdef USE_PGXS
+PG_CONFIG = pg_config
+PGXS := $(shell $(PG_CONFIG) --pgxs)
+include $(PGXS)
+else
+subdir = contrib/tablefunc
+top_builddir = ../..
+include $(top_builddir)/src/Makefile.global
+include $(top_srcdir)/contrib/contrib-global.mk
+endif