summaryrefslogtreecommitdiffstats
path: root/contrib/vacuumlo/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/vacuumlo/Makefile')
-rw-r--r--contrib/vacuumlo/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/contrib/vacuumlo/Makefile b/contrib/vacuumlo/Makefile
new file mode 100644
index 0000000..6bc7b34
--- /dev/null
+++ b/contrib/vacuumlo/Makefile
@@ -0,0 +1,25 @@
+# contrib/vacuumlo/Makefile
+
+PGFILEDESC = "vacuumlo - removes orphaned large objects"
+PGAPPICON = win32
+
+PROGRAM = vacuumlo
+OBJS = \
+ $(WIN32RES) \
+ vacuumlo.o
+
+TAP_TESTS = 1
+
+PG_CPPFLAGS = -I$(libpq_srcdir)
+PG_LIBS_INTERNAL = $(libpq_pgport)
+
+ifdef USE_PGXS
+PG_CONFIG = pg_config
+PGXS := $(shell $(PG_CONFIG) --pgxs)
+include $(PGXS)
+else
+subdir = contrib/vacuumlo
+top_builddir = ../..
+include $(top_builddir)/src/Makefile.global
+include $(top_srcdir)/contrib/contrib-global.mk
+endif