summaryrefslogtreecommitdiffstats
path: root/src/makefiles/Makefile.freebsd
diff options
context:
space:
mode:
Diffstat (limited to 'src/makefiles/Makefile.freebsd')
-rw-r--r--src/makefiles/Makefile.freebsd19
1 files changed, 19 insertions, 0 deletions
diff --git a/src/makefiles/Makefile.freebsd b/src/makefiles/Makefile.freebsd
new file mode 100644
index 0000000..75db21b
--- /dev/null
+++ b/src/makefiles/Makefile.freebsd
@@ -0,0 +1,19 @@
+AROPT = cr
+
+export_dynamic = -Wl,-export-dynamic
+rpath = -Wl,-R'$(rpathdir)'
+
+DLSUFFIX = .so
+
+# extra stuff for $(with_temp_install)
+# we need this to get LD_LIBRARY_PATH searched ahead of the compiled-in
+# rpath, if no DT_RUNPATH is present in the executable. The conditions
+# under which DT_RUNPATH are added seem unpredictable, so be safe.
+
+define with_temp_install_extra
+LD_LIBRARY_PATH_RPATH=1
+endef
+
+# Rule for building a shared library from a single .o file
+%.so: %.o
+ $(CC) $(CFLAGS) $< $(LDFLAGS) $(LDFLAGS_SL) -shared -o $@