summaryrefslogtreecommitdiffstats
path: root/src/makefiles/Makefile.linux
diff options
context:
space:
mode:
Diffstat (limited to 'src/makefiles/Makefile.linux')
-rw-r--r--src/makefiles/Makefile.linux13
1 files changed, 13 insertions, 0 deletions
diff --git a/src/makefiles/Makefile.linux b/src/makefiles/Makefile.linux
new file mode 100644
index 0000000..645f73a
--- /dev/null
+++ b/src/makefiles/Makefile.linux
@@ -0,0 +1,13 @@
+AROPT = crs
+
+export_dynamic = -Wl,-E
+# Use --enable-new-dtags to generate DT_RUNPATH instead of DT_RPATH.
+# This allows LD_LIBRARY_PATH to still work when needed.
+rpath = -Wl,-rpath,'$(rpathdir)',--enable-new-dtags
+
+DLSUFFIX = .so
+
+
+# Rule for building a shared library from a single .o file
+%.so: %.o
+ $(CC) $(CFLAGS) $< $(LDFLAGS) $(LDFLAGS_SL) -shared -o $@