summaryrefslogtreecommitdiffstats
path: root/src/makefiles/Makefile.openbsd
diff options
context:
space:
mode:
Diffstat (limited to 'src/makefiles/Makefile.openbsd')
-rw-r--r--src/makefiles/Makefile.openbsd11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/makefiles/Makefile.openbsd b/src/makefiles/Makefile.openbsd
new file mode 100644
index 0000000..6f9cb1d
--- /dev/null
+++ b/src/makefiles/Makefile.openbsd
@@ -0,0 +1,11 @@
+AROPT = cr
+
+export_dynamic = -Wl,-E
+rpath = -Wl,-R'$(rpathdir)'
+
+DLSUFFIX = .so
+
+
+# Rule for building a shared library from a single .o file
+%.so: %.o
+ $(CC) $(CFLAGS) $< $(LDFLAGS) $(LDFLAGS_SL) -shared -o $@