summaryrefslogtreecommitdiffstats
path: root/src/makefiles/Makefile.solaris
diff options
context:
space:
mode:
Diffstat (limited to 'src/makefiles/Makefile.solaris')
-rw-r--r--src/makefiles/Makefile.solaris23
1 files changed, 23 insertions, 0 deletions
diff --git a/src/makefiles/Makefile.solaris b/src/makefiles/Makefile.solaris
new file mode 100644
index 0000000..62a6c01
--- /dev/null
+++ b/src/makefiles/Makefile.solaris
@@ -0,0 +1,23 @@
+# src/makefiles/Makefile.solaris
+
+AROPT = crs
+
+ifeq ($(with_gnu_ld), yes)
+export_dynamic = -Wl,-E
+rpath = -Wl,-rpath,'$(rpathdir)'
+else
+rpath = -Wl,-R'$(rpathdir)'
+endif
+
+DLSUFFIX = .so
+
+
+# Rule for building a shared library from a single .o file
+%.so: %.o
+ifeq ($(GCC), yes)
+ $(CC) $(CFLAGS) $< $(LDFLAGS) $(LDFLAGS_SL) -shared -o $@
+else
+ $(CC) $(CFLAGS) $< $(LDFLAGS) $(LDFLAGS_SL) -G -o $@
+endif
+
+sqlmansect = 5sql