summaryrefslogtreecommitdiffstats
path: root/contrib/ltree/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:15:05 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:15:05 +0000
commit46651ce6fe013220ed397add242004d764fc0153 (patch)
tree6e5299f990f88e60174a1d3ae6e48eedd2688b2b /contrib/ltree/Makefile
parentInitial commit. (diff)
downloadpostgresql-14-upstream.tar.xz
postgresql-14-upstream.zip
Adding upstream version 14.5.upstream/14.5upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'contrib/ltree/Makefile')
-rw-r--r--contrib/ltree/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/contrib/ltree/Makefile b/contrib/ltree/Makefile
new file mode 100644
index 0000000..b16a566
--- /dev/null
+++ b/contrib/ltree/Makefile
@@ -0,0 +1,34 @@
+# contrib/ltree/Makefile
+
+MODULE_big = ltree
+OBJS = \
+ $(WIN32RES) \
+ _ltree_gist.o \
+ _ltree_op.o \
+ crc32.o \
+ lquery_op.o \
+ ltree_gist.o \
+ ltree_io.o \
+ ltree_op.o \
+ ltxtquery_io.o \
+ ltxtquery_op.o
+PG_CPPFLAGS = -DLOWER_NODE
+
+EXTENSION = ltree
+DATA = ltree--1.1--1.2.sql ltree--1.1.sql ltree--1.0--1.1.sql
+PGFILEDESC = "ltree - hierarchical label data type"
+
+HEADERS = ltree.h
+
+REGRESS = ltree
+
+ifdef USE_PGXS
+PG_CONFIG = pg_config
+PGXS := $(shell $(PG_CONFIG) --pgxs)
+include $(PGXS)
+else
+subdir = contrib/ltree
+top_builddir = ../..
+include $(top_builddir)/src/Makefile.global
+include $(top_srcdir)/contrib/contrib-global.mk
+endif