summaryrefslogtreecommitdiffstats
path: root/src/backend/bootstrap/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:15:05 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:15:05 +0000
commit46651ce6fe013220ed397add242004d764fc0153 (patch)
tree6e5299f990f88e60174a1d3ae6e48eedd2688b2b /src/backend/bootstrap/Makefile
parentInitial commit. (diff)
downloadpostgresql-14-upstream.tar.xz
postgresql-14-upstream.zip
Adding upstream version 14.5.upstream/14.5upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/backend/bootstrap/Makefile')
-rw-r--r--src/backend/bootstrap/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/src/backend/bootstrap/Makefile b/src/backend/bootstrap/Makefile
new file mode 100644
index 0000000..6421efb
--- /dev/null
+++ b/src/backend/bootstrap/Makefile
@@ -0,0 +1,25 @@
+#-------------------------------------------------------------------------
+#
+# Makefile for the bootstrap module
+#
+# src/backend/bootstrap/Makefile
+#
+#-------------------------------------------------------------------------
+
+subdir = src/backend/bootstrap
+top_builddir = ../../..
+include $(top_builddir)/src/Makefile.global
+
+override CPPFLAGS := -I. -I$(srcdir) $(CPPFLAGS)
+
+OBJS = \
+ bootparse.o \
+ bootstrap.o
+
+include $(top_srcdir)/src/backend/common.mk
+
+# bootscanner is compiled as part of bootparse
+bootparse.o: bootscanner.c
+
+# bootparse.c and bootscanner.c are in the distribution tarball, so
+# they are not cleaned here.