summaryrefslogtreecommitdiffstats
path: root/src/bin/pgbench/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:15:05 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:15:05 +0000
commit46651ce6fe013220ed397add242004d764fc0153 (patch)
tree6e5299f990f88e60174a1d3ae6e48eedd2688b2b /src/bin/pgbench/Makefile
parentInitial commit. (diff)
downloadpostgresql-14-upstream.tar.xz
postgresql-14-upstream.zip
Adding upstream version 14.5.upstream/14.5upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/bin/pgbench/Makefile')
-rw-r--r--src/bin/pgbench/Makefile54
1 files changed, 54 insertions, 0 deletions
diff --git a/src/bin/pgbench/Makefile b/src/bin/pgbench/Makefile
new file mode 100644
index 0000000..f402fe7
--- /dev/null
+++ b/src/bin/pgbench/Makefile
@@ -0,0 +1,54 @@
+# src/bin/pgbench/Makefile
+
+PGFILEDESC = "pgbench - a simple program for running benchmark tests"
+PGAPPICON = win32
+
+subdir = src/bin/pgbench
+top_builddir = ../../..
+include $(top_builddir)/src/Makefile.global
+
+OBJS = \
+ $(WIN32RES) \
+ exprparse.o \
+ pgbench.o
+
+override CPPFLAGS := -I. -I$(srcdir) -I$(libpq_srcdir) $(CPPFLAGS)
+LDFLAGS_INTERNAL += -L$(top_builddir)/src/fe_utils -lpgfeutils $(libpq_pgport)
+
+ifneq ($(PORTNAME), win32)
+override CFLAGS += $(PTHREAD_CFLAGS)
+endif
+LIBS += $(PTHREAD_LIBS)
+
+
+all: pgbench
+
+pgbench: $(OBJS) | submake-libpq submake-libpgport submake-libpgfeutils
+ $(CC) $(CFLAGS) $^ $(LDFLAGS) $(LDFLAGS_EX) $(LIBS) -o $@$(X)
+
+# exprscan is compiled as part of exprparse
+exprparse.o: exprscan.c
+
+distprep: exprparse.c exprscan.c
+
+install: all installdirs
+ $(INSTALL_PROGRAM) pgbench$(X) '$(DESTDIR)$(bindir)/pgbench$(X)'
+
+installdirs:
+ $(MKDIR_P) '$(DESTDIR)$(bindir)'
+
+uninstall:
+ rm -f '$(DESTDIR)$(bindir)/pgbench$(X)'
+
+clean distclean:
+ rm -f pgbench$(X) $(OBJS)
+ rm -rf tmp_check
+
+maintainer-clean: distclean
+ rm -f exprparse.c exprscan.c
+
+check:
+ $(prove_check)
+
+installcheck:
+ $(prove_installcheck)