summaryrefslogtreecommitdiffstats
path: root/contrib/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:17:33 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:17:33 +0000
commit5e45211a64149b3c659b90ff2de6fa982a5a93ed (patch)
tree739caf8c461053357daa9f162bef34516c7bf452 /contrib/Makefile
parentInitial commit. (diff)
downloadpostgresql-15-5e45211a64149b3c659b90ff2de6fa982a5a93ed.tar.xz
postgresql-15-5e45211a64149b3c659b90ff2de6fa982a5a93ed.zip
Adding upstream version 15.5.upstream/15.5
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'contrib/Makefile')
-rw-r--r--contrib/Makefile97
1 files changed, 97 insertions, 0 deletions
diff --git a/contrib/Makefile b/contrib/Makefile
new file mode 100644
index 0000000..bbf2204
--- /dev/null
+++ b/contrib/Makefile
@@ -0,0 +1,97 @@
+# contrib/Makefile
+
+subdir = contrib
+top_builddir = ..
+include $(top_builddir)/src/Makefile.global
+
+SUBDIRS = \
+ adminpack \
+ amcheck \
+ auth_delay \
+ auto_explain \
+ basic_archive \
+ basebackup_to_shell \
+ bloom \
+ btree_gin \
+ btree_gist \
+ citext \
+ cube \
+ dblink \
+ dict_int \
+ dict_xsyn \
+ earthdistance \
+ file_fdw \
+ fuzzystrmatch \
+ hstore \
+ intagg \
+ intarray \
+ isn \
+ lo \
+ ltree \
+ oid2name \
+ old_snapshot \
+ pageinspect \
+ passwordcheck \
+ pg_buffercache \
+ pg_freespacemap \
+ pg_prewarm \
+ pg_stat_statements \
+ pg_surgery \
+ pg_trgm \
+ pgrowlocks \
+ pgstattuple \
+ pg_visibility \
+ pg_walinspect \
+ postgres_fdw \
+ seg \
+ spi \
+ tablefunc \
+ tcn \
+ test_decoding \
+ tsm_system_rows \
+ tsm_system_time \
+ unaccent \
+ vacuumlo
+
+ifeq ($(with_ssl),openssl)
+SUBDIRS += pgcrypto sslinfo
+else
+ALWAYS_SUBDIRS += pgcrypto sslinfo
+endif
+
+ifneq ($(with_uuid),no)
+SUBDIRS += uuid-ossp
+else
+ALWAYS_SUBDIRS += uuid-ossp
+endif
+
+ifeq ($(with_libxml),yes)
+SUBDIRS += xml2
+else
+ALWAYS_SUBDIRS += xml2
+endif
+
+ifeq ($(with_selinux),yes)
+SUBDIRS += sepgsql
+else
+ALWAYS_SUBDIRS += sepgsql
+endif
+
+ifeq ($(with_perl),yes)
+SUBDIRS += bool_plperl hstore_plperl jsonb_plperl
+else
+ALWAYS_SUBDIRS += bool_plperl hstore_plperl jsonb_plperl
+endif
+
+ifeq ($(with_python),yes)
+SUBDIRS += hstore_plpython jsonb_plpython ltree_plpython
+else
+ALWAYS_SUBDIRS += hstore_plpython jsonb_plpython ltree_plpython
+endif
+
+# Missing:
+# start-scripts \ (does not have a makefile)
+
+
+$(recurse)
+$(recurse_always)