summaryrefslogtreecommitdiffstats
path: root/contrib/dict_int/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:17:33 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:17:33 +0000
commit5e45211a64149b3c659b90ff2de6fa982a5a93ed (patch)
tree739caf8c461053357daa9f162bef34516c7bf452 /contrib/dict_int/Makefile
parentInitial commit. (diff)
downloadpostgresql-15-5e45211a64149b3c659b90ff2de6fa982a5a93ed.tar.xz
postgresql-15-5e45211a64149b3c659b90ff2de6fa982a5a93ed.zip
Adding upstream version 15.5.upstream/15.5
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'contrib/dict_int/Makefile')
-rw-r--r--contrib/dict_int/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/contrib/dict_int/Makefile b/contrib/dict_int/Makefile
new file mode 100644
index 0000000..2ff1bdb
--- /dev/null
+++ b/contrib/dict_int/Makefile
@@ -0,0 +1,23 @@
+# contrib/dict_int/Makefile
+
+MODULE_big = dict_int
+OBJS = \
+ $(WIN32RES) \
+ dict_int.o
+
+EXTENSION = dict_int
+DATA = dict_int--1.0.sql
+PGFILEDESC = "dict_int - add-on dictionary template for full-text search"
+
+REGRESS = dict_int
+
+ifdef USE_PGXS
+PG_CONFIG = pg_config
+PGXS := $(shell $(PG_CONFIG) --pgxs)
+include $(PGXS)
+else
+subdir = contrib/dict_int
+top_builddir = ../..
+include $(top_builddir)/src/Makefile.global
+include $(top_srcdir)/contrib/contrib-global.mk
+endif