summaryrefslogtreecommitdiffstats
path: root/contrib/lo/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:17:33 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:17:33 +0000
commit5e45211a64149b3c659b90ff2de6fa982a5a93ed (patch)
tree739caf8c461053357daa9f162bef34516c7bf452 /contrib/lo/Makefile
parentInitial commit. (diff)
downloadpostgresql-15-5e45211a64149b3c659b90ff2de6fa982a5a93ed.tar.xz
postgresql-15-5e45211a64149b3c659b90ff2de6fa982a5a93ed.zip
Adding upstream version 15.5.upstream/15.5
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'contrib/lo/Makefile')
-rw-r--r--contrib/lo/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/contrib/lo/Makefile b/contrib/lo/Makefile
new file mode 100644
index 0000000..7168938
--- /dev/null
+++ b/contrib/lo/Makefile
@@ -0,0 +1,20 @@
+# contrib/lo/Makefile
+
+MODULES = lo
+
+EXTENSION = lo
+DATA = lo--1.1.sql lo--1.0--1.1.sql
+PGFILEDESC = "lo - management for large objects"
+
+REGRESS = lo
+
+ifdef USE_PGXS
+PG_CONFIG = pg_config
+PGXS := $(shell $(PG_CONFIG) --pgxs)
+include $(PGXS)
+else
+subdir = contrib/lo
+top_builddir = ../..
+include $(top_builddir)/src/Makefile.global
+include $(top_srcdir)/contrib/contrib-global.mk
+endif