summaryrefslogtreecommitdiffstats
path: root/src/backend/optimizer/geqo/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:17:33 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:17:33 +0000
commit5e45211a64149b3c659b90ff2de6fa982a5a93ed (patch)
tree739caf8c461053357daa9f162bef34516c7bf452 /src/backend/optimizer/geqo/Makefile
parentInitial commit. (diff)
downloadpostgresql-15-5e45211a64149b3c659b90ff2de6fa982a5a93ed.tar.xz
postgresql-15-5e45211a64149b3c659b90ff2de6fa982a5a93ed.zip
Adding upstream version 15.5.upstream/15.5
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/backend/optimizer/geqo/Makefile')
-rw-r--r--src/backend/optimizer/geqo/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/src/backend/optimizer/geqo/Makefile b/src/backend/optimizer/geqo/Makefile
new file mode 100644
index 0000000..1978c14
--- /dev/null
+++ b/src/backend/optimizer/geqo/Makefile
@@ -0,0 +1,33 @@
+#-------------------------------------------------------------------------
+#
+# Makefile--
+# Makefile for the genetic query optimizer module
+#
+# Copyright (c) 1994, Regents of the University of California
+#
+# src/backend/optimizer/geqo/Makefile
+#
+#-------------------------------------------------------------------------
+
+subdir = src/backend/optimizer/geqo
+top_builddir = ../../../..
+include $(top_builddir)/src/Makefile.global
+
+OBJS = \
+ geqo_copy.o \
+ geqo_cx.o \
+ geqo_erx.o \
+ geqo_eval.o \
+ geqo_main.o \
+ geqo_misc.o \
+ geqo_mutation.o \
+ geqo_ox1.o \
+ geqo_ox2.o \
+ geqo_pmx.o \
+ geqo_pool.o \
+ geqo_px.o \
+ geqo_random.o \
+ geqo_recombination.o \
+ geqo_selection.o
+
+include $(top_srcdir)/src/backend/common.mk