summaryrefslogtreecommitdiffstats
path: root/src/bin/pgevent/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:17:33 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:17:33 +0000
commit5e45211a64149b3c659b90ff2de6fa982a5a93ed (patch)
tree739caf8c461053357daa9f162bef34516c7bf452 /src/bin/pgevent/Makefile
parentInitial commit. (diff)
downloadpostgresql-15-5e45211a64149b3c659b90ff2de6fa982a5a93ed.tar.xz
postgresql-15-5e45211a64149b3c659b90ff2de6fa982a5a93ed.zip
Adding upstream version 15.5.upstream/15.5
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/bin/pgevent/Makefile')
-rw-r--r--src/bin/pgevent/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/src/bin/pgevent/Makefile b/src/bin/pgevent/Makefile
new file mode 100644
index 0000000..dea79d3
--- /dev/null
+++ b/src/bin/pgevent/Makefile
@@ -0,0 +1,38 @@
+#-------------------------------------------------------------------------
+#
+# Makefile for src/bin/pgevent
+#
+# Copyright (c) 1996-2022, PostgreSQL Global Development Group
+#
+#-------------------------------------------------------------------------
+
+PGFILEDESC = "Eventlog message formatter"
+PGAPPICON=win32
+
+subdir = src/bin/pgevent
+top_builddir = ../../..
+include $(top_builddir)/src/Makefile.global
+
+ifeq ($(PORTNAME), win32)
+
+OBJS = \
+ pgevent.o \
+ pgmsgevent.o
+NAME=pgevent
+
+SHLIB_LINK =
+SHLIB_EXPORTS = exports.txt
+
+all: all-lib
+
+install: all install-lib
+
+include $(top_srcdir)/src/Makefile.shlib
+
+pgmsgevent.o: pgmsgevent.rc win32ver.rc
+ $(WINDRES) $< -o $@ --include-dir=$(top_builddir)/src/include --include-dir=$(top_srcdir)/src/include --include-dir=$(srcdir) --include-dir=.
+
+clean distclean: clean-lib
+ rm -f $(OBJS) win32ver.rc
+
+endif