summaryrefslogtreecommitdiffstats
path: root/contrib/dblink/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/dblink/Makefile')
-rw-r--r--contrib/dblink/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/contrib/dblink/Makefile b/contrib/dblink/Makefile
new file mode 100644
index 0000000..d4c7ed6
--- /dev/null
+++ b/contrib/dblink/Makefile
@@ -0,0 +1,27 @@
+# contrib/dblink/Makefile
+
+MODULE_big = dblink
+OBJS = \
+ $(WIN32RES) \
+ dblink.o
+PG_CPPFLAGS = -I$(libpq_srcdir)
+SHLIB_LINK_INTERNAL = $(libpq)
+
+EXTENSION = dblink
+DATA = dblink--1.2.sql dblink--1.1--1.2.sql dblink--1.0--1.1.sql
+PGFILEDESC = "dblink - connect to other PostgreSQL databases"
+
+REGRESS = dblink
+REGRESS_OPTS = --dlpath=$(top_builddir)/src/test/regress
+
+ifdef USE_PGXS
+PG_CONFIG = pg_config
+PGXS := $(shell $(PG_CONFIG) --pgxs)
+include $(PGXS)
+else
+SHLIB_PREREQS = submake-libpq
+subdir = contrib/dblink
+top_builddir = ../..
+include $(top_builddir)/src/Makefile.global
+include $(top_srcdir)/contrib/contrib-global.mk
+endif