summaryrefslogtreecommitdiffstats
path: root/doc/src/sgml/images/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'doc/src/sgml/images/Makefile')
-rw-r--r--doc/src/sgml/images/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/doc/src/sgml/images/Makefile b/doc/src/sgml/images/Makefile
new file mode 100644
index 0000000..6455190
--- /dev/null
+++ b/doc/src/sgml/images/Makefile
@@ -0,0 +1,27 @@
+# doc/src/sgml/images/Makefile
+#
+# see README in this directory about image handling
+
+ALL_IMAGES = \
+ genetic-algorithm.svg \
+ gin.svg \
+ pagelayout.svg
+
+DITAA = ditaa
+DOT = dot
+XSLTPROC = xsltproc --nonet
+
+all: $(ALL_IMAGES)
+
+%.svg.tmp: %.gv
+ $(DOT) -T svg -o $@ $<
+
+%.svg.tmp: %.txt
+ $(DITAA) -E -S --svg $< $@
+
+# Post-processing for SVG files coming from other tools
+#
+# Use --novalid to avoid loading SVG DTD if a file specifies it, since
+# it might not be available locally, and we don't need it.
+%.svg: %.svg.tmp fixup-svg.xsl
+ $(XSLTPROC) --novalid -o $@ $(word 2,$^) $<