summaryrefslogtreecommitdiffstats
path: root/src/test/examples/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/test/examples/Makefile')
-rw-r--r--src/test/examples/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/src/test/examples/Makefile b/src/test/examples/Makefile
new file mode 100644
index 0000000..a67f456
--- /dev/null
+++ b/src/test/examples/Makefile
@@ -0,0 +1,22 @@
+#
+# Makefile for example programs
+#
+
+subdir = src/test/examples
+top_builddir = ../../..
+include $(top_builddir)/src/Makefile.global
+
+ifeq ($(PORTNAME), win32)
+LDFLAGS += -lws2_32
+endif
+
+override CPPFLAGS := -I$(libpq_srcdir) $(CPPFLAGS)
+LDFLAGS_INTERNAL += $(libpq_pgport)
+
+
+PROGS = testlibpq testlibpq2 testlibpq3 testlibpq4 testlo testlo64
+
+all: $(PROGS)
+
+clean distclean maintainer-clean:
+ rm -f $(PROGS) *.o