summaryrefslogtreecommitdiffstats
path: root/src/test/modules/test_rls_hooks/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/test/modules/test_rls_hooks/Makefile')
-rw-r--r--src/test/modules/test_rls_hooks/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/src/test/modules/test_rls_hooks/Makefile b/src/test/modules/test_rls_hooks/Makefile
new file mode 100644
index 0000000..14ccc35
--- /dev/null
+++ b/src/test/modules/test_rls_hooks/Makefile
@@ -0,0 +1,20 @@
+# src/test/modules/test_rls_hooks/Makefile
+
+MODULE_big = test_rls_hooks
+OBJS = \
+ $(WIN32RES) \
+ test_rls_hooks.o
+PGFILEDESC = "test_rls_hooks - example use of RLS hooks"
+
+REGRESS = test_rls_hooks
+
+ifdef USE_PGXS
+PG_CONFIG = pg_config
+PGXS := $(shell $(PG_CONFIG) --pgxs)
+include $(PGXS)
+else
+subdir = src/test/modules/test_rls_hooks
+top_builddir = ../../../..
+include $(top_builddir)/src/Makefile.global
+include $(top_srcdir)/contrib/contrib-global.mk
+endif