summaryrefslogtreecommitdiffstats
path: root/tests/roots/test-pycode-egg/src
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 11:31:33 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 11:31:33 +0000
commite863fd965dd6253243c3342bd6f0adc4fc8aec4d (patch)
treea4c1b6491a82593950043c3f8b2530e80664d768 /tests/roots/test-pycode-egg/src
parentInitial commit. (diff)
downloadsphinx-e863fd965dd6253243c3342bd6f0adc4fc8aec4d.tar.xz
sphinx-e863fd965dd6253243c3342bd6f0adc4fc8aec4d.zip
Adding upstream version 5.3.0.upstream/5.3.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/roots/test-pycode-egg/src')
-rw-r--r--tests/roots/test-pycode-egg/src/sample.py6
-rw-r--r--tests/roots/test-pycode-egg/src/setup.py4
2 files changed, 10 insertions, 0 deletions
diff --git a/tests/roots/test-pycode-egg/src/sample.py b/tests/roots/test-pycode-egg/src/sample.py
new file mode 100644
index 0000000..2ecf577
--- /dev/null
+++ b/tests/roots/test-pycode-egg/src/sample.py
@@ -0,0 +1,6 @@
+#: constant on sample.py
+CONSTANT = 1
+
+
+def hello(s):
+ print('Hello %s' % s)
diff --git a/tests/roots/test-pycode-egg/src/setup.py b/tests/roots/test-pycode-egg/src/setup.py
new file mode 100644
index 0000000..1dfb1de
--- /dev/null
+++ b/tests/roots/test-pycode-egg/src/setup.py
@@ -0,0 +1,4 @@
+from setuptools import setup
+
+setup(name='sample',
+ py_modules=['sample'])