summaryrefslogtreecommitdiffstats
path: root/Makefile.docker
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-05 17:42:34 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-05 17:42:34 +0000
commit271164583de5842c9093ef4e2866196b24dc6109 (patch)
treec6d060dd47ad362d3e6d3f5311b4398d0b894f4f /Makefile.docker
parentInitial commit. (diff)
downloadssh-audit-upstream.tar.xz
ssh-audit-upstream.zip
Adding upstream version 2.5.0.upstream/2.5.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'Makefile.docker')
-rw-r--r--Makefile.docker13
1 files changed, 13 insertions, 0 deletions
diff --git a/Makefile.docker b/Makefile.docker
new file mode 100644
index 0000000..3028f2c
--- /dev/null
+++ b/Makefile.docker
@@ -0,0 +1,13 @@
+VERSION = $(shell grep VERSION src/ssh_audit/globals.py | grep -E -o "'(v.*)'" | tr -d "'")
+ifeq ($(VERSION),)
+ $(error "could not determine version!")
+endif
+
+all:
+ docker build -t positronsecurity/ssh-audit:${VERSION} .
+ docker tag positronsecurity/ssh-audit:${VERSION} positronsecurity/ssh-audit:latest
+
+upload:
+ docker login
+ docker push positronsecurity/ssh-audit:${VERSION}
+ docker push positronsecurity/ssh-audit:latest