summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-05 17:42:34 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-05 17:42:34 +0000
commitcc48f16d89067e4f467e751a9bcd8655593676be (patch)
tree55edbc70cc15fbea316d503a625137e67ab3f4a9 /debian/rules
parentAdding upstream version 2.5.0. (diff)
downloadssh-audit-cc48f16d89067e4f467e751a9bcd8655593676be.tar.xz
ssh-audit-cc48f16d89067e4f467e751a9bcd8655593676be.zip
Adding debian version 2.5.0-1.debian/2.5.0-1debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules20
1 files changed, 20 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..f9fc986
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,20 @@
+#!/usr/bin/make -f
+#export DH_VERBOSE = 1
+
+%:
+ dh $@ --with python3 --buildsystem=pybuild
+
+override_dh_auto_configure:
+ cat debian/*manpages | sed 's/$$/.txt/p' | xargs -n 1 a2x --doctype manpage --format manpage
+ dh_auto_configure
+
+override_dh_python3:
+ dh_python3 --shebang=/usr/bin/python3
+
+override_dh_auto_test:
+ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
+ PYTHONPATH=$(CURDIR)/src py.test-3
+endif
+
+override_dh_clean:
+ dh_clean $(CURDIR)/src/*.egg-info/