summaryrefslogtreecommitdiffstats
path: root/src/shutdown/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 15:35:18 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 15:35:18 +0000
commitb750101eb236130cf056c675997decbac904cc49 (patch)
treea5df1a06754bdd014cb975c051c83b01c9a97532 /src/shutdown/meson.build
parentInitial commit. (diff)
downloadsystemd-b750101eb236130cf056c675997decbac904cc49.tar.xz
systemd-b750101eb236130cf056c675997decbac904cc49.zip
Adding upstream version 252.22.upstream/252.22
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/shutdown/meson.build')
-rw-r--r--src/shutdown/meson.build15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/shutdown/meson.build b/src/shutdown/meson.build
new file mode 100644
index 0000000..0bd09fd
--- /dev/null
+++ b/src/shutdown/meson.build
@@ -0,0 +1,15 @@
+# SPDX-License-Identifier: LGPL-2.1-or-later
+
+systemd_shutdown_sources = files(
+ 'shutdown.c',
+ 'umount.c',
+ 'umount.h',
+)
+
+tests += [
+ [files('test-umount.c',
+ 'umount.c',
+ 'umount.h'),
+ [],
+ [libmount]],
+]