summaryrefslogtreecommitdiffstats
path: root/debian/patches/install.diff
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-05 17:41:35 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-05 17:41:35 +0000
commit9c80e2b0a6da1aab8c99efc9200d15f1124dc8c4 (patch)
tree7611716063eca933355f485079046f3cb2141e0c /debian/patches/install.diff
parentAdding upstream version 4.99.3. (diff)
downloadtcpdump-9c80e2b0a6da1aab8c99efc9200d15f1124dc8c4.tar.xz
tcpdump-9c80e2b0a6da1aab8c99efc9200d15f1124dc8c4.zip
Adding debian version 4.99.3-1.debian/4.99.3-1debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/patches/install.diff')
-rw-r--r--debian/patches/install.diff25
1 files changed, 25 insertions, 0 deletions
diff --git a/debian/patches/install.diff b/debian/patches/install.diff
new file mode 100644
index 0000000..b4642ef
--- /dev/null
+++ b/debian/patches/install.diff
@@ -0,0 +1,25 @@
+Change man page install paths for Debian and don't install
+a versioned binary.
+
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -424,15 +424,14 @@
+ [ -d $(DESTDIR)$(bindir) ] || \
+ (mkdir -p $(DESTDIR)$(bindir); chmod 755 $(DESTDIR)$(bindir))
+ $(INSTALL_PROGRAM) $(PROG) $(DESTDIR)$(bindir)/$(PROG)
+- $(INSTALL_PROGRAM) $(PROG) $(DESTDIR)$(bindir)/$(PROG).`cat ${srcdir}/VERSION`
+- [ -d $(DESTDIR)$(mandir)/man1 ] || \
+- (mkdir -p $(DESTDIR)$(mandir)/man1; chmod 755 $(DESTDIR)$(mandir)/man1)
+- $(INSTALL_DATA) $(PROG).1 $(DESTDIR)$(mandir)/man1/$(PROG).1
++ [ -d $(DESTDIR)$(mandir)/man8 ] || \
++ (mkdir -p $(DESTDIR)$(mandir)/man8; chmod 755 $(DESTDIR)$(mandir)/man8)
++ $(INSTALL_DATA) $(PROG).1 $(DESTDIR)$(mandir)/man8/$(PROG).8
+
+ uninstall:
+ rm -f $(DESTDIR)$(bindir)/$(PROG)
+ rm -f $(DESTDIR)$(bindir)/$(PROG).`cat ${srcdir}/VERSION`
+- rm -f $(DESTDIR)$(mandir)/man1/$(PROG).1
++ rm -f $(DESTDIR)$(mandir)/man8/$(PROG).8
+
+ lint:
+ lint -hbxn $(SRC) $(LIBNETDISSECT_SRC) | \