summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules16
2 files changed, 3 insertions, 15 deletions
diff --git a/debian/control b/debian/control
index 2e1b97d..c9dd267 100644
--- a/debian/control
+++ b/debian/control
@@ -6,7 +6,7 @@ XSBC-Uploaders: Daniel Baumann <daniel.baumann@progress-linux.org>
XSBC-Original-Maintainer: Luca Boccassi <bluca@debian.org>
Bugs: mailto:maintainers@lists.progress-linux.org
Rules-Requires-Root: no
-Build-Depends: bpftool,
+Build-Depends: bpftool (>= 7.1),
clang,
debhelper-compat (= 13),
libbpf-dev,
diff --git a/debian/rules b/debian/rules
index 7497f1d..ceabf38 100755
--- a/debian/rules
+++ b/debian/rules
@@ -12,6 +12,8 @@ ifneq (,$(filter $(DEB_HOST_MULTIARCH), mips64el-linux-gnuabi64 mipsel-linux-gnu
export BPF_CFLAGS+= -D__MIPSEL__=1
endif
+export BPFTOOL=/usr/sbin/bpftool
+
ifneq (,$(findstring terse,$(DEB_BUILD_OPTIONS)))
export VERBOSE=0
else
@@ -23,17 +25,3 @@ endif
# Tests require root and break the testbed
override_dh_auto_test:
-
-execute_before_dh_auto_build:
- # On Ubuntu, the `bpftool` in path is a shell wrapper pointing at
- # the binary corresponding to runtime kernel version.
- #
- # We do not know the kernel version being used on the system building
- # this package, and for the build we only need the tool to generate
- # skeleton code.
- #
- # If /usr/lib/linux-tools-*/bpftool exists, locate the most recent
- # version and point to that, otherwise `bpftool` from PATH will be
- # used.
- for _bpftool in $(ls /usr/lib/linux-tools-*/bpftool); do true;done
- if [ -x "$_bpftool" ]; then export BPFTOOL=$_bpftool; fi